Upgrade Cluster

From Roaring Penguin
Revision as of 13:25, 12 March 2014 by MCoyne (talk | contribs) (Created page with "You should upgrade your CanIt cluster by: 1) Stop CanIt on both machines: /etc/init.d/canit-system stop 2) Upgrade CanIt on the primary database: upgrade-canit-applianc…")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

You should upgrade your CanIt cluster by:

1) Stop CanIt on both machines:

  /etc/init.d/canit-system stop

2) Upgrade CanIt on the primary database:

  upgrade-canit-appliance

Note that the "Upgrading Database" part may appear to "hang" for a bit because it doesn't print anything; it's not hung, it's just working without printing anything, so do NOT interrupt it.

3) Upgrade CanIt on antispam2 AFTER antispam1 finishes:

  upgrade-canit-appliance

Then, if you use Database Failover, you'll need to:

4) Delete the existing WAL files in /var/backups/postgres/wal/:

  rm /var/backups/postgres/wal/00000001*

5) Re-initialise the "base backup":

  canit-failover-init.pl

Because of the link speed between the machines, this could take a long time - let it run to completion!